icon Top 9 categories map      RocketAware > man pages >

mount_fdesc(8)

Tips: Browse or Search all pages for efficient awareness of more than 6000 of the most popular reusable and open source applications, functions, libraries, and FAQs.


The "RKT couplings" below include links to source code, updates, additional information, advice, FAQs, and overviews.


Home

Search all pages


Subjects

By activity
Professions, Sciences, Humanities, Business, ...

User Interface
Text-based, GUI, Audio, Video, Keyboards, Mouse, Images,...

Text Strings
Conversions, tests, processing, manipulation,...

Math
Integer, Floating point, Matrix, Statistics, Boolean, ...

Processing
Algorithms, Memory, Process control, Debugging, ...

Stored Data
Data storage, Integrity, Encryption, Compression, ...

Communications
Networks, protocols, Interprocess, Remote, Client Server, ...

Hard World
Timing, Calendar and Clock, Audio, Video, Printer, Controls...

File System
Management, Filtering, File & Directory access, Viewers, ...

    

RocketLink!--> Man page versions: OpenBSD NetBSD



MOUNT_FDESC(8)          OpenBSD System Manager's Manual         MOUNT_FDESC(8)

NAME
     mount_fdesc - mount the file-descriptor file system



SYNOPSIS
     mount_fdesc [-o options] fdesc mount_point

DESCRIPTION
     The mount_fdesc command attaches an instance of the per-process file de-
     scriptor namespace to the global filesystem namespace.  The conventional
     mount point is /dev and the filesystem should be union mounted in order
     to augment, rather than replace, the existing entries in /dev. This com-
     mand is normally executed by mount(8) at boot time.

     The options are as follows:

     -o      Options are specified with a -o flag followed by a comma separat-
             ed string of options.  See the mount(8) man page for possible op-
             tions and their meanings.

     The contents of the mount point are fd, stderr, stdin, stdout and tty.

     fd is a directory whose contents appear as a list of numbered files which
     correspond to the open files of the process reading the directory.  The
     files /dev/fd/0 through /dev/fd/# refer to file descriptors which can be
     accessed through the file system.  If the file descriptor is open and the
     mode the file is being opened with is a subset of the mode of the exist-
     ing descriptor, the call:

           fd = open("/dev/fd/0", mode);

     and the call:

           fd = fcntl(0, F_DUPFD, 0);

     are equivalent.

     The files /dev/stdin, /dev/stdout and /dev/stderr appear as symlinks to
     the relevant entry in the /dev/fd sub-directory.  Opening them is equiva-
     lent to the following calls:

           fd = fcntl(STDIN_FILENO,  F_DUPFD, 0);
           fd = fcntl(STDOUT_FILENO, F_DUPFD, 0);
           fd = fcntl(STDERR_FILENO, F_DUPFD, 0);

     Flags to the open(2) call other than O_RDONLY, O_WRONLY and O_RDWR are
     ignored.

     The /dev/tty entry is an indirect reference to the current process's con-
     trolling terminal.  It appears as a named pipe (FIFO) but behaves in ex-
     actly the same way as the real controlling terminal device.

FILES
     /dev/fd/#
     /dev/stdin
     /dev/stdout
     /dev/stderr
     /dev/tty

SEE ALSO
     mount(2),  unmount(2),  tty(4),  fstab(5),  mount(8)

CAVEATS
     This filesystem may not be NFS-exported.

HISTORY
     The mount_fdesc utility first appeared in 4.4BSD.

4.4BSD                          March 27, 1994                               2

Source: OpenBSD 2.6 man pages. Copyright: Portions are copyrighted by BERKELEY
SOFTWARE DESIGN, INC., The Regents of the University of California, Massachusetts
Institute of Technology, Free Software Foundation, FreeBSD Inc., and others.



(Corrections, notes, and links courtesy of RocketAware.com)


[Detailed Topics]
OpenBSD sources for mount_fdesc(8)


[Overview Topics]

Up to: Specific Types of File Systems - Specific forms of file systems. DFS, NFS, MS-DOS, etc.
Up to: File System Operations - Operations for entire file-systems (quotas, configuration, consistency, mount, unmount, et al)


RocketLink!--> Man page versions: OpenBSD NetBSD






Rapid-Links: Search | About | Comments | Submit Path: RocketAware > man pages > mount_fdesc.8/
RocketAware.com is a service of Mib Software
Copyright 1999, Forrest J. Cavalier III. All Rights Reserved.
We welcome submissions and comments