icon Top 9 categories map      RocketAware > man pages >

mount(8)

Tips: Browse or Search all pages for efficient awareness of more than 6000 of the most popular reusable and open source applications, functions, libraries, and FAQs.


The "RKT couplings" below include links to source code, updates, additional information, advice, FAQs, and overviews.


Home

Search all pages


Subjects

By activity
Professions, Sciences, Humanities, Business, ...

User Interface
Text-based, GUI, Audio, Video, Keyboards, Mouse, Images,...

Text Strings
Conversions, tests, processing, manipulation,...

Math
Integer, Floating point, Matrix, Statistics, Boolean, ...

Processing
Algorithms, Memory, Process control, Debugging, ...

Stored Data
Data storage, Integrity, Encryption, Compression, ...

Communications
Networks, protocols, Interprocess, Remote, Client Server, ...

Hard World
Timing, Calendar and Clock, Audio, Video, Printer, Controls...

File System
Management, Filtering, File & Directory access, Viewers, ...

    

RocketLink!--> Man page versions: OpenBSD FreeBSD NetBSD Others



MOUNT(8)                OpenBSD System Manager's Manual               MOUNT(8)

NAME
     mount - mount file systems



SYNOPSIS
     mount [-Aadfruvw] [-t type]
     mount [-dfruvw] special | node
     mount [-dfruvw] [-o options] [-t type] special node

DESCRIPTION
     The mount command invokes a filesystem-specific program to prepare and
     graft the special device or remote node (rhost:path) on to the file sys-
     tem tree at the point node. If either special or node are not provided,
     the appropriate information is taken from the fstab(5) file.

     The system maintains a list of currently mounted file systems.  If no ar-
     guments are given to mount, this list is printed.

     The options are as follows:

     -A      Causes mount to try to mount all of the file systems listed in
             the fstab(5) table except those for which the ``noauto'' option
             is specified.

     -a      Similar to the -A flag, except that if a file system (other than
             the root file system) appears to be already mounted, mount will
             not try to mount it again.  Mount assumes that a file system is
             already mounted if a file system with the same type is mounted on
             the given mount point.  More stringent checks are not possible
             because some file system types report strange values for the
             mounted-from device for mounted file systems.

     -d      Causes everything to be done except for the invocation of the
             filesystem-specific program.  This option is useful in conjunc-
             tion with the -v flag to determine what the mount command is try-
             ing to do.

     -f      Forces the revocation of write access when trying to downgrade a
             filesystem mount status from read-write to read-only.

     -o      Options are specified with a -o flag followed by a comma separat-
             ed string of options.  The following options are available:

             async   All I/O to the file system should be done asynchronously.
                     This is a dangerous flag to set, and should not be used
                     unless you are prepared to recreate the file system
                     should your system crash.

             force   The same as -f; forces the revocation of write access
                     when trying to downgrade a filesystem mount status from
                     read-write to read-only.

             noatime
                     Do not update atime on files in the system unless the
                     mtime or ctime is being changed as well.  This option is
                     useful for laptops and news servers where one does not
                     want the extra disk activity associated with updating the
                     atime.

             noaccesstime
                     Synonym for noatime provided for compatibility with other
                     OS's.

             nodev   Do not interpret character or block special devices on
                     the file system.  This option is useful for a server that
                     has file systems containing special devices for architec-
                     tures other than its own.

             noexec  Do not allow execution of any binaries on the mounted
                     file system.  This option is useful for a server that has
                     file systems containing binaries for architectures other
                     than its own.

             nosuid  Do not allow set-user-identifier or set-group-identifier
                     bits to take effect.

             rdonly  The same as -r; mount the file system read-only (even the
                     super-user may not write it).

             sync    All I/O to the file system should be done synchronously.

             update  The same as -u; indicate that the status of an already
                     mounted file system should be changed.

             union   Causes the namespace at the mount point to appear as the
                     union of the mounted filesystem root and the existing di-
                     rectory.  Lookups will be done in the mounted filesystem
                     first.  If those operations fail due to a non-existent
                     file the underlying directory is then accessed.  All cre-
                     ates are done in the mounted filesystem.

             Any additional options specific to a given filesystem type (see
             the -t option) may be passed as a comma separated list; these op-
             tions are distinguished by a leading ``-'' (dash).  Options that
             take a value are specified using the syntax -option=value.  For
             example, the mount command:

                   mount -t mfs -o nosuid,-N,-s=4000 /dev/dk0b /tmp

             causes mount to execute the equivalent of:

                   /sbin/mount_mfs -o nosuid -N -s 4000 /dev/dk0b /tmp

     -r      The file system is to be mounted read-only.  Mount the file sys-
             tem read-only (even the super-user may not write it).  The same
             as the ``rdonly'' argument to the -o option.

     -t type
             The argument following the -t is used to indicate the file system
             type.  The type ffs is the default.  The -t option can be used to
             indicate that the actions should only be taken on filesystems of
             the specified type.  More than one type may be specified in a
             comma separated list.  The list of filesystem types can be pre-
             fixed with ``no'' to specify the filesystem types for which ac-
             tion should not be taken.  For example, the mount command:

                   mount -a -t nonfs,mfs

             mounts all filesystems except those of type NFS and MFS.

             Mount will attempt to execute a program in /sbin/mount_XXX where
             XXX is replaced by the type name.  For example, nfs filesystems
             are mounted by the program /sbin/mount_nfs.

     -u      The -u flag indicates that the status of an already mounted file
             system should be changed.  Any of the options discussed above
             (the -o option) may be changed; also a file system can be changed
             from read-only to read-write or vice versa.  An attempt to change
             from read-write to read-only will fail if any files on the
             filesystem are currently open for writing unless the -f flag is
             also specified.  The set of options is determined by first ex-
             tracting the options for the file system from the fstab(5) table,
             then applying any options specified by the -o argument, and fi-
             nally applying the -r or -w option.

     -v      Verbose mode.

     -w      The file system object is to be read and write.

     The options specific to the various file system types are described in
     the manual pages for those file systems' mount_XXX commands.  For in-
     stance the options specific to Berkekely Fast File Systems are described
     in the mount_ffs(8) manual page.

FILES
     /etc/fstab  file system table

SEE ALSO
     mount(2),  fstab(5),  mount_ados(8),  mount_cd9660(8),  mount_fdesc(8),
     mount_ffs(8),  mount_kernfs(8),  mount_lfs(8),  mount_mfs(8),
     mount_msdos(8),  mount_nfs(8),  mount_null(8),  mount_portal(8),
     mount_procfs(8),  mount_umap(8),  mount_union(8),  umount(8)

HISTORY
     A mount command appeared in Version 6 AT&T UNIX.

4th Berkeley Distribution       March 27, 1994                               3

Source: OpenBSD 2.6 man pages. Copyright: Portions are copyrighted by BERKELEY
SOFTWARE DESIGN, INC., The Regents of the University of California, Massachusetts
Institute of Technology, Free Software Foundation, FreeBSD Inc., and others.



(Corrections, notes, and links courtesy of RocketAware.com)


[Detailed Topics]
FreeBSD Sources for mount(8)
OpenBSD sources for mount(8)


[Overview Topics]

Up to: File System Operations - Operations for entire file-systems (quotas, configuration, consistency, mount, unmount, et al)


RocketLink!--> Man page versions: OpenBSD FreeBSD NetBSD Others






Rapid-Links: Search | About | Comments | Submit Path: RocketAware > man pages > mount.8/
RocketAware.com is a service of Mib Software
Copyright 1999, Forrest J. Cavalier III. All Rights Reserved.
We welcome submissions and comments