icon Top 9 categories map      RocketAware > man pages >

modload(8)

Tips: Browse or Search all pages for efficient awareness of more than 6000 of the most popular reusable and open source applications, functions, libraries, and FAQs.


The "RKT couplings" below include links to source code, updates, additional information, advice, FAQs, and overviews.


Home

Search all pages


Subjects

By activity
Professions, Sciences, Humanities, Business, ...

User Interface
Text-based, GUI, Audio, Video, Keyboards, Mouse, Images,...

Text Strings
Conversions, tests, processing, manipulation,...

Math
Integer, Floating point, Matrix, Statistics, Boolean, ...

Processing
Algorithms, Memory, Process control, Debugging, ...

Stored Data
Data storage, Integrity, Encryption, Compression, ...

Communications
Networks, protocols, Interprocess, Remote, Client Server, ...

Hard World
Timing, Calendar and Clock, Audio, Video, Printer, Controls...

File System
Management, Filtering, File & Directory access, Viewers, ...

    

RocketLink!--> Man page versions: OpenBSD NetBSD



MODLOAD(8)              OpenBSD System Manager's Manual             MODLOAD(8)

NAME
     modload - load a kernel module



SYNOPSIS
     modload [-dvuv] [-A kernel] [-e entry] [-p postinstall] [-o output_file]
             input_file

DESCRIPTION
     The modload utility loads a loadable kernel module into a running system.
     The input file is an object file (.o file).

     The options to modload are as follows:

     -d      Debug.  Used to debug modload itself.

     -q      Be very quiet.

     -u      Delete the loaded module (output_file) after loading.  If the
             output file was not specified, this option causes the temporary
             file to be kept rather than deleted.

     -v      Print comments about the loading process.

     -A kernel
             Specify the file that is passed to the linker to resolve module
             references to external symbols.  The symbol file must be for the
             currently running kernel or the module is likely to crash the
             system.

     -e entry
             Specify the module entry point.  This is passed by modload to
             ld(1) when the module is linked.  The default module entry point
             name is `xxxinit'.

     -p postinstall
             Specify the name of a shell script or program that will be exe-
             cuted if the module is successfully loaded. It is always passed
             the module id (in decimal) and module type (in hexadecimal) as
             the first two arguments.  For loadable drivers, the third argu-
             ment is the block or character major device number.  For a load-
             able system call, the third argument is the system call number.

     -o output_file
             Specify the name of the output file that is produced by the link-
             er.  If this option is not specified, a file in the /tmp directo-
             ry is used with the name generated from the module name with a
             `.out' extension.

FILES
     /bsd                    default file passed to the linker to resolve ex-
                             ternal references in the module
     /usr/include/sys/lkm.h  file containing definitions of module types

DIAGNOSTICS
     The modload utility exits with a status of 0 on success and with a nonze-
     ro status if an error occurs.

SEE ALSO
     ld(1),  lkm(4),  modstat(8),  modunload(8)

HISTORY
     The modload command was designed to be similar in functionality to the
     corresponding command in SunOS 4.1.3.

AUTHOR
     Terrence R. Lambert, terry@cs.weber.edu

BUGS
     The loadable device driver framework can only reserve either a character
     or block device entry, not both.

OpenBSD 2.3                      June 7, 1993                                2

Source: OpenBSD 2.6 man pages. Copyright: Portions are copyrighted by BERKELEY
SOFTWARE DESIGN, INC., The Regents of the University of California, Massachusetts
Institute of Technology, Free Software Foundation, FreeBSD Inc., and others.



(Corrections, notes, and links courtesy of RocketAware.com)


[Detailed Topics]
FreeBSD Sources for modload(8)
OpenBSD sources for modload(8)


[Overview Topics]

Up to: Local machine and Operating System Information - kernel topics, uname, boot, shutdown, et al


RocketLink!--> Man page versions: OpenBSD NetBSD






Rapid-Links: Search | About | Comments | Submit Path: RocketAware > man pages > modload.8/
RocketAware.com is a service of Mib Software
Copyright 1999, Forrest J. Cavalier III. All Rights Reserved.
We welcome submissions and comments