icon Top 9 categories map      RocketAware > man pages >

compat_linux(8)

Tips: Browse or Search all pages for efficient awareness of more than 6000 of the most popular reusable and open source applications, functions, libraries, and FAQs.


The "RKT couplings" below include links to source code, updates, additional information, advice, FAQs, and overviews.


Home

Search all pages


Subjects

By activity
Professions, Sciences, Humanities, Business, ...

User Interface
Text-based, GUI, Audio, Video, Keyboards, Mouse, Images,...

Text Strings
Conversions, tests, processing, manipulation,...

Math
Integer, Floating point, Matrix, Statistics, Boolean, ...

Processing
Algorithms, Memory, Process control, Debugging, ...

Stored Data
Data storage, Integrity, Encryption, Compression, ...

Communications
Networks, protocols, Interprocess, Remote, Client Server, ...

Hard World
Timing, Calendar and Clock, Audio, Video, Printer, Controls...

File System
Management, Filtering, File & Directory access, Viewers, ...

    

RocketLink!--> Man page versions: OpenBSD NetBSD



compat_linux(8)         OpenBSD System Manager's Manual        compat_linux(8)

NAME
     compat_linux - setup procedure for running Linux binaries under emulation



DESCRIPTION
     OpenBSD supports running Linux binaries. This only applies to i386 sys-
     tems for now. Both the a.out and ELF binary formats are supported. Most
     programs should work, including the ones that use the Linux SVGAlib. Pro-
     grams that will not work include the Linux /proc filesystem (which is
     different from the optional OpenBSD /proc filesystem), and i386-specific
     calls, such as enabling virtual 8086 mode. Currently, sound is not sup-
     ported for Linux binaries (they will probably run, but not produce any
     sound).

     The Linux compatibility feature is active for kernels compiled with the
     COMPAT_LINUX option enabled.

     A lot of programs are dynamically linked. This means, that you will also
     need the Linux shared libraries that the program depends on, and the run-
     time linker. Also, you will need to create a "shadow root" directory for
     Linux binaries on your OpenBSD system. This directory is named /emul/lin-
     ux. Any file operations done by Linux programs run under OpenBSD will
     look in this directory first. So, if a Linux program opens, for example,
     /etc/passwd, OpenBSD will first try to open /emul/linux/etc/passwd, and
     if that does not exist open the 'real' /etc/passwd file. It is recommend-
     ed that you install Linux packages that include configuration files, etc
     under /emul/linux, to avoid naming conflicts with possible OpenBSD coun-
     terparts. Shared libraries should also be installed in the shadow tree.

     Generally, you will need to look for the shared libraries that Linux bi-
     naries depend on only the first few times that you install a Linux pro-
     gram on your OpenBSD system. After a while, you will have a sufficient
     set of Linux shared libraries on your system to be able to run newly im-
     ported Linux binaries without any extra work.


   Setting up shared libraries
     How to get to know which shared libraries Linux binaries need, and where
     to get them? Basically, there are 2 possibilities (when following these
     instructions: you will need to be root on your OpenBSD system to do the
     necessary installation steps).

     1.   You have access to a Linux system. In this case you can temporarily
          install the binary there, see what shared libraries it needs, and
          copy them to your OpenBSD system. Example: you have just ftp-ed the
          Linux binary of Doom. Put it on the Linux system you have access to,
          and check which shared libraries it needs by running `ldd lin-
          uxxdoom':

                (me@linux) ldd linuxxdoom
                     libXt.so.3 (DLL Jump 3.1) => /usr/X11/lib/libXt.so.3.1.0
                     libX11.so.3 (DLL Jump 3.1) => /usr/X11/lib/libX11.so.3.1.0
                     libc.so.4 (DLL Jump 4.5pl26) => /lib/libc.so.4.6.29

          You would need go get all the files from the last column, and put
          them under /emul/linux, with the names in the first column as sym-
          bolic links pointing to them. This means you eventually have these
          files on your OpenBSD system:

          /emul/linux/usr/X11/lib/libXt.so.3.1.0
          /emul/linux/usr/X11/lib/libXt.so.3 (symbolic link to the above)
          /emul/linux/usr/X11/lib/libX11.so.3.1.0
          /emul/linux/usr/X11/lib/libX11.so.3 (symbolic link to the above)
          /emul/linux/lib/libc.so.4.6.29
          /emul/linux/lib/libc.so.4 (symbolic link to the above)

          Note that if you already have a Linux shared library with a matching
          major revision number to the first column of the 'ldd' output, you
          won't need to copy the file named in the last column to your system,
          the one you already have should work. It is advisable to copy the
          shared library anyway if it is a newer version, though. You can re-
          move the old one, as long as you make the symbolic link point to the
          new one. So, if you have these libraries on your system:

          /emul/linux/lib/libc.so.4.6.27
          /emul/linux/lib/libc.so.4 -> /emul/linux/lib/libc.so.4.6.27

          and you find that the ldd output for a new binary you want to in-
          stall is:

          libc.so.4 (DLL Jump 4.5pl26) => /lib/libc.so.4.6.29

          you won't need to worry about copying /lib/libc.so.4.6.29 too, be-
          cause the program should work fine with the slightly older version.
          You can decide to replace the libc.so anyway, and that should leave
          you with:

          /emul/linux/lib/libc.so.4.6.29
          /emul/linux/lib/libc.so.4 -> /emul/linux/lib/libc.so.4.6.29

          Please note that the symbolic link mechanism is only needed for Lin-
          ux binaries, the OpenBSD runtime linker takes care of looking for
          matching major revision numbers itself, you don't need to worry
          about that.

          Finally, you must make sure that you have the Linux runtime linker
          and its config files on your system. You should copy these files
          from the Linux system to their appropriate place on your OpenBSD
          system (in the /emul/linux tree):

          /lib/ld.so
          /etc/ld.so.cache
          /etc/ld.so.config

     2.   You don't have access to a Linux system. In that case, you should
          get the extra files you need from various ftp sites.  Information on
          where to look for the various files is appended below. For now,
          let's assume you know where to get the files.

          Retrieve the following files (from _one_ ftp site to avoid any ver-
          sion mismatches), and install them under /emul/linux (i.e. /foo/bar
          is installed as /emul/linux/foo/bar):

          /sbin/ldconfig
          /usr/bin/ldd
          /lib/libc.so.x.y.z
          /lib/ld.so

          ldconfig and ldd don't necessarily need to be under /emul/linux, you
          can install them elsewhere in the system too. Just make sure they
          don't conflict with their OpenBSD counterparts. A good idea would be
          to install them in /usr/local/bin as ldconfig-linux and ldd-linux.

          Create the file /emul/linux/etc/ld.so.conf, containing the directo-
          ries in which the Linux runtime linker should look for shared libs.
          It is a plain text file, containing a directory name on each line.
          /lib and /usr/lib are standard, you could add the following:

          /usr/X11/lib
          /usr/local/lib

          Note that these are mapped to /emul/linux/XXXX by OpenBSD's compat
          code, and should exist as such on your system.

          Run the Linux ldconfig program. It should be statically linked, so
          it doesn't need any shared libraries by itself.  It will create the
          file /emul/linux/etc/ld.so.cache You should rerun the Linux version
          of the ldconfig program each time you add a new shared library.

          You should now be set up for Linux binaries which only need a shared
          libc. You can test this by running the Linux ldd on itself. Suppose
          that you have it installed as ldd-linux, it should produce something
          like:

                % ldd-linux `which ldd-linux`
                     libc.so.4 (DLL Jump 4.5pl26) => /lib/libc.so.4.6.29

          This being done, you are ready to install new Linux binaries.  When-
          ever you install a new Linux program, you should check if it needs
          shared libraries, and if so, whether you have them installed in the
          /emul/linux tree. To do this, you run the Linux version ldd on the
          new program, and watch its output.  ldd (see also the manual page
          for ldd(1)) will print a list of shared libraries that the program
          depends on, in the form  <majorname> (<jumpversion>) => <fullname>.

          If it prints "not found" in stead of <fullname> it means that you
          need an extra library. Which library this is, is shown in <major-
          name>, which will be of the form libXXXX.so.<N> You will need to
          find a libXXXX.so.<N>.<mm> on a Linux ftp site, and install it on
          your system. The XXXX (name) and <N> (major revision number) should
          match; the minor number(s) <mm> are less important, though it is ad-
          vised to take the most recent version.


   Finding the necessary files.
     Note: the information below is valid as of the ime this document was
     written (March, 1995), but certain details such as names of ftp sites,
     directories and distribution names may have changed by the time you read
     this.

     Linux is distributed by several groups that make their own set of bina-
     ries that they distribute. Each distribution has its own name, like
     "Slackware" or "Yggdrasil". The distributions are available on a lot of
     ftp sites. Sometimes the files are unpacked, and you can get the individ-
     ual files you need, but mostly they are stored in distribution sets, usu-
     ally consisting of subdirectories with gzipped tar files in them. The
     primary ftp sites for the distributions are:

     sunsite.unc.edu:/pub/Linux/distributions
     tsx-11.mit.edu:/pub/linux/distributions

     Some European mirrors:

     ftp.luth.se:/pub/linux/distributions
     ftp.demon.co.uk:/pub/linux/distributions
     src.doc.ic.ac.uk:/packages/linux/distributions

     For simplicity, let's concentrate on Slackware here. This distribution
     consists of a number of subdirectories, containing separate packages.
     Normally, they're controlled by an install program, but you can retrieve
     files "by hand" too. First of all, you will need to look in the "con-
     tents" subdir of the distribution. You will find a lot of small textfiles
     here describing the contents of the seperate packages. The fastest way to
     look something up is to retrieve all the files in the contents subdirec-
     tory, and grep through them for the file you need. Here is an example of
     a list of files that you might need, and in which contents-file you will
     find it by grepping through them:

           Needed                  Package

           ld.so                   ldso
           ldconfig                ldso
           ldd                     ldso
           libc.so.4               shlibs
           libX11.so.6.0           xf_lib
           libXt.so.6.0            xf_lib
           libX11.so.3             oldlibs
           libXt.so.3              oldlibs

     So, in this case, you will need the packages ldso, shlibs, xf_lib and
     oldlibs.  In each of the contents-files for these packages, look for a
     line saying "PACKAGE LOCATION", it will tell you on which 'disk' the
     package is, in our case it will tell us in which subdirectory we need to
     look.  For our example, we would find the following locations:

           Package                 Location

           ldso                    diska2
           shlibs                  diska2
           oldlibs                 diskx6
           xf_lib                  diskx9

     The locations called "diskXX" refer to the "slakware/XX" subdirectories
     of the distribution, others may be found in the "contrib" subdirectory.
     In this case, we could now retrieve the packages we need by retrieving
     the following files (relative to the root of the Slackware distribution
     tree):

     slakware/a2/ldso.tgz
     slakware/a2/shlibs.tgz
     slakware/x6/oldlibs/tgz
     slakware/x9/xf_lib.tgz

     Extract the files from these gzipped tarfiles in your /emul/linux direc-
     tory (possibly omitting or afterwards removing files you don't need), and
     you are done.


   Programs using SVGAlib
     SVGAlib binaries require some extra care. The pcvt virtual console driver
     has to be in the kernel for them to work, and you will also have to cre-
     ate some symbloic links in the /emul/linux/dev directory, namely:

     /emul/linux/dev/console -> /dev/tty
     /emul/linux/dev/mouse -> whatever device your mouse is connected to
     /emul/linux/dev/ttyS0 -> /dev/tty00
     /emul/linux/dev/ttyS1 -> /dev/tty01

     Be warned: the first link mentioned here makes SVGAlib binaries work, but
     may confuse others, so you may have to remove it again at some point.

BUGS
     The information about Linux distributions may become outdated.

4th Berkeley Distribution        March 2, 1995                               4

Source: OpenBSD 2.6 man pages. Copyright: Portions are copyrighted by BERKELEY
SOFTWARE DESIGN, INC., The Regents of the University of California, Massachusetts
Institute of Technology, Free Software Foundation, FreeBSD Inc., and others.



(Corrections, notes, and links courtesy of RocketAware.com)


[Detailed Topics]


[Overview Topics]



RocketLink!--> Man page versions: OpenBSD NetBSD






Rapid-Links: Search | About | Comments | Submit Path: RocketAware > man pages > compat_linux.8/
RocketAware.com is a service of Mib Software
Copyright 1999, Forrest J. Cavalier III. All Rights Reserved.
We welcome submissions and comments